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Screenshot recipes
This chapter contains step-by-step procedures for performing a wide range of screenshot tasks. 
The tasks included here range from Windows desktop and tools configuration, to techniques for 
capturing and manipulating the most common types of screenshots in use in Ab Initio 
documentation.

 Screenshot standardization goals

 Screenshot process overview

 Configuring your Windows 7 desktop envrionment

 Installing Snagit Profiles and Quick Styles

 Using Snagit Profiles and Quick Styles

 Preparing the UI component to be captured

 Taking a screenshot

 Editing a screenshot

 Saving images in P4

 Resizing Visio drawings

 Importing an image into FrameMaker

 Review: Screenshot order of events

 Useful screenshot-related numbers
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Screenshot standardization goals
The Ab Initio online help sets collectively contain more than 4,500 individual image files. Such 
large numbers demand a focused level of consistency in presentation to prevent the product 
documentation from appearing like a disjointed mess.

Screenshots currently represent nearly 60% of the 4,500+ images files in our help sets, so 
establishing consistency with regard to our screenshot tools, procedures, and styles is particularly 
important.

The goals of screenshot standardization are to:

 Make screenshots easier and faster to create

 Make the screenshot process more efficient

 Make great looking images

 Make thousands of images look like they come from the same company

 Reliably produce consistent and repeatable results

 Minimize surprises at production time

With these goals in mind, the Ab Initio documentation team has standardized on Snagit 9 for 
screen captures. Moreover, we have customized Snagit with a number of Profile sets and Quick 
Style palettes to make it fast and easy to apply consistent styles and image sizes that work well 
with FrameMaker. Instructions for installing and using these Snagit customizations are provided in 
Installing Snagit Profiles and Quick Styles and Using Snagit Profiles and Quick Styles.

But what if I don’t want to use Snagit?
Some writers may prefer to use tools other than SnagIt to perform screen captures. For example, 
several writers prefer to use Paint Shop Pro. While no one is going to stop you from using other 
tools for your screenshots, if you do choose to use another tool, it is up to you to replicate the 
graphic styles — for example, line weights, arrows, tear-off styles, and font effects — that have 
been designed in SnagIt. Consistency in tools less important than consistency in results, which are 
very important indeed.

Our custom Snagit Profiles and Quick Styles have been designed to make things as easy and fast 
as possible. Moreover, some Snagit styles, particularly tear-offs, are very difficult to replicate 
outside Snagit. Also note that every additional tool we introduce into our workflow is another 
tool that the localization writers need to work with, potentially increasing localization costs.

Finally, peer help is available for Snagit, and all our screenshot instructions are written based on 
Snagit. If you use a tool other htna Snagit, you are truly on your own. We simply do not have 
sufficient time and resources to customize and support tools other than Snagit.
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Screenshot process overview
Before proceeding with the individual procedures in this chapter, it is useful to review the overall 
process for capturing and manipiulating screenshots. Briefly, this process comprises the following 
steps:

1. Configure your Windows 7 desktop environment.

It is important that, as much as possible, all screenshots start out from desktop environments 
that are consistent in terms of color, background, fonts, window shapes, and UI component 
sizes. See Configuring your Windows 7 desktop envrionment for instructions.

NOTE:  We are standardizing for now on Windows 7 because, among other things, it has good Unicode 

font support and windows with nice round corners that people won’t cut themselves on.

2. Configure SnagIt.

The standard tool used by the documentation group to perform screen captures and 
modifications is SnagIt. Several pre-configured SnagIt capture profiles and custom tool 
palettes (tear-off edges, lines, arrows, type effects, stamps) have been created to make screen 
capture and modification as efficient, consistent, and simple as possible. See Using Snagit 
Profiles and Quick Styles for instructions.

3. Prepare whatever it is you want to capture.

Initial sizing of your UI components — for example, a browser window — with an eye 
towards how it will fit in the online help window can be made easier by using the on-screen 
ruler we have in our bag o’ goodies. See Preparing the UI component to be captured for 
instructions.

4. Choose the SnagIt profile best suited for your needs.

We have profiles defined for capturing a window, an individual object, multiple objects, print 
spooling, and performing automatic image scaling, among others. See Choosing a Snagit 
Profile for instructions.

5. Perform the capture.

The image will be opened in the SnagIt Editor, from which you can modify the image as 
needed. See Taking a screenshot for instructions.

6. Modify the image, if needed.

Several SnagIt quick palettes have been created to provide the basis for many modifications. 
See Editing a screenshot for instructions.

7. Save the image in native SnagIt format.

Unlike saving in a raster format, like .PNG, .JPG, or .GIF, saving the image in native SnagIt 
(.SNAG) format maintains the editability of text, lines, callouts, and other objects. See Saving 
an image for instructions.

8. Export your completed images in .PNG format.

You can export your .SNAG files as .PNG one file at a time as you work through a series of 
images. However, SnagIt also provides a bulk export feature, which may be more convenient 
in some cases than performing multiple individual exports. For example, when you are done 
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capturing and modifying, say, three or more images, you can perform a bulk export of all the 
images at once to .PNG format. See Saving an image for instructions.

NOTE:  The Ab Initio production documentation currently contains a mix of .PNG, .GIF, and .JPG image 

files. This variety of formats is a product of accretion rather than plan. Moving forward, the decision has 

been made to save all image files in .PNG format.

9. Submit your files to P4.

Images should be saved in a figures subdirectory in the directory that contains your Frame 
book files. Note that if an image you have created may be considered a “reusable” — that is, 
someone else may want to use it also — you should save it in the top-level workspace 
directory named Figures-Common. See Saving an image for instructions.

10. Import your image files by reference in Frame.

See Importing an image into FrameMaker for instructions.

At the risk of getting too prickly, note the following truly important rules:

a. Always import image files into Frame by reference; never embed them.

b. Never resize, scale, or crop images in Frame.

c. Do not use the Frame drawing tools. Just say no.

d. Do not create image captions or callouts in Frame; do all that in SnagIt (or Illustrator or 
Visio, if you’re making a conceptual illustration).
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Configuring your Windows 7 desktop envrionment
Before capturing screenshots that include Windows UI components, such as complete windows, 
dialog buttons, tabs, and suchlike, it is important that the appearance of our Windows 7 desktop 
environments be unobstrusive and consistent from machine to machine.

The easiest way to define and quickly recall Windows appearance settings is to use the Windows 
7 theme engine.

NOTE:  These instructions apply to Windows 7, and not to XP. In many cases, the appearance of your 

Windows environment will be irrelevant because the native Windows UI components will not be shown 

in your screenshots. For example, when capturing graphs or components within browser-based 

applications, in most cases native Windows UI components will not be part of the image. However, 

when capturing components that do include native Windows UI components, you should create those 

screenshots on a Windows 7 machine because, for example, Windows 7 dialog buttons look different 

than Windows XP dialog buttons. For example, in most cases, it will be necessary to capture GDE dialogs 

on a Windows 7 machine.

X To define the default screenshot theme in Windows 7

1. Right-click on your Windows 7 desktop and select Personalize from pop-up menu.
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2. Click the Windows 7 Basic theme button in the Basic and High Contrast Themes section.

3. Click the Desktop background button.

4. Select Solid Colors from the Picture location drop-down list.
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5. Select the medium gray color (fourth from left in top row), and then click Save Changes.

6. Click Save theme to save the theme for easy recall later.

7. Give the theme a name, say, "Screenshot," and then click Save.
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8. Recall the theme at a later time by returning the Windows 7 Personalization screen and 
clicking the name of the screenshot theme in the My Themes section.
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Installing Snagit Profiles and Quick Styles
Use the procedures in this section to install the custom Ab Initio Snagit Profile sets and Quick 
Style palettes. After installing the Profiles, you may also want to rearrange the order in which the 
Profiles are displayed in Snagit and enable the Snagit OneClick feature.

 Installing the Snagit Profile sets

 Installing the Snagit Quick Style sets

 Organizing Snagit Profiles

 Enabling the Snagit OneClick feature

 Displaying the Snagit icon in the Windows System Tray

NOTE:  The instructions in this section are based on Snagit version 9.x. Instructions for other Snagit 

versions may vary.

Installing the Snagit Profile sets
The custom Ab Initio Snagit Profiles are compiled in two Profile sets:

 Ab Initio - General.snagprof — Common Profiles for general screen capture tasks

 Ab Initio - Resize.snagprof — Profiles that automatically resize and trim captured images 
based on our FrameMaker anchor tags.

These Profile sets are explained in more detail in Using Snagit Profiles and Quick Styles.

X To install the Snagit Profile sets:

1. Navigate to the main\doc_central\eng\Figures-Common directory in P4.

2. Double-click the Ab Initio - General.snagprof file to launch the Profile installer.

Scott Fordin

Scott Fordin



AB INITIO CONFIDENTIAL AND PROPRIETARY — DO NOT COPY 18 

DRAFT  INTERNAL USE ONLY

Alternatively, you can copy the Ab Initio - General.snagprof file from P4 to the directory of 
your choice, and then double-click the file in Windows Explorer.

3. Leave all checkboxes unselected when prompted, and then click OK to import the Profile set.

4. Repeat steps 2 and 3 to install the Ab Initio - Resize.snagprof Profile set.

Installing the Snagit Quick Style sets
The custom Ab Initio Snagit Quick Styles are compiled in two palette sets:

 DrawQuickStyles.xml — Image tab Quick Styles for tear-offs

 ImageQuickStyles.xml — Draw tab Quick Styles for lines, arrows, shapes, text, and callouts

These Quick Style sets are explained in more detail in Using Snagit Profiles and Quick Styles.

X To install the Snagit Quick Style sets:

1. Exit all Snagit programs, including the Snagit main application, the Snagit Editor, and the 
Snagit System Tray applet.

2. Navigate to the main\doc_central\eng\Figures-Common directory in P4.

3. Copy the following two files to the local directory of your choice:

 DrawQuickStyles.xml

 ImageQuickStyles.xml

4. In Windows Explorer, navigate to the 
C:\Users\your_user_name\AppData\Local\TechSmith\Snagit directory.

If using Windows XP, navigate instead to C:\Documents and Settings\your_user_name\Local 

Settings\Application Data\TechSmith\Snagit.

5. Copy your existing DrawQuickStyles.xml and ImageQuickStyles.xml files to some other 
location, if there's anything in those files you want to save.

6. Replace the existing DrawQuickStyles.xml and ImageQuickStyles.xml files with the ones you 
copied from P4.

7. Restart Snagit.
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Organizing Snagit Profiles
You can add, remove, modify, and organize Snagit Profiles and Profile sets to suit your work style. 
Complete instructions for managing Snagit Profiles are provided in the Snagit online help, but for 
purposes of using the custom Ab Initio Snagit Profiles, you may find it useful to move the Ab 
Initio Profile sets to the top of your Profiles list.

X To move the custom Ab Initio Snagit Profile sets to the top of your Profile list:

1. Open the Snagit main window (not the Snagit Editor).

2. Click Organize Profiles on the left side of the Snagit main window.
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3. Select the Ab Initio - General Profile set, and then click the Up Arrow icon to move the entire 
set to the top of the list.

4. Repeat the bove step, this time moving the Ab Initio - Resize Profile set up the list, so it 
appears below the Ab Initio - General set.

5. When you are done rearranging Profiles, click Close to exit the Oranize Profiles dialog.

Enabling the Snagit OneClick feature
You may find it useful to turn on Snagit’s OneClick feature, which makes it easy to access 
different Snagit Profiles with a single mouse click.

X To enable the Snagit OneClick feature:

1. Open the Snagit main window (not the Snagit Editor).
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2. Click Turn on OneClick on the left side of the Snagit main window.

The Snagit OneClick pop-up window is anchored to one of the edges of your Windows 
desktop. The pop-up window displays briefly, and then automatically retracts to hide out of 
the way.
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3. To display the OneClick pop-up window, hover your mouse near the edge of your Windows 
desktop where the orange OneClick pop-up anchor is displayed.

The specific location of the pop-anchor may vary according to your desktop configuration. In 
the figure below, the pop-up anchor is displayed on the lower right edge of the Windows 
desktop.

You can move the pop-up anchor location by dragging the OneClick window to the desired 
edge of your desktop. You can also resize the OneClick window, as desired.

X To use a Snagit Profile through OneClick:

1. Hover your mouse over the pop-up anchor to display the OneClick window.

2. Click the name of the Profile you want to use.

The screen capture is initiated using the selected Profile.

Displaying the Snagit icon in the Windows System Tray
By default, the main Snagit application minimizes to the Windows System Tray. There are a 
number of Snagit program features, including Profile selection, that you can access by right-
clicking this System Tray icon. However, depending on how your Windows System Tray is 
configured, the Snagit icon may not be displayed.

If necessary, you can use the following procedure to enable the display of the Snagit icon in the 
Windows System Tray.

X To enable the display of the Snagit icon in the Windows 7 System Tray:

1. Right-click the Windows Task Bar, and select Properties from the pop-up menu.
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2. Click the Customize button.

3. Choose one of the following options:

 Select Always show all icons and notifications on the task bar.

 Select Show icon and notifications for just the Snagit icon.
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4. Right-click the Snagit icon in the Windows System Tray to display the Snagit pop-up menu.
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Using Snagit Profiles and Quick Styles
Briefly, the purposes of Snagit Profiles and Quick Styles can be summarized as follows:

 Profiles make capturing images of various kinds of UI components easier and more consistent 
than manually fiddling with configuration settings, selecting UI components, and performing 
basic post-capture tasks. For example, with a single mouse click and then dragging a 
rectangular selection, the AB_Region - anchor_body Profile automatically trims the selection, 
resizes it to fit in the maximum allowable width for the FrameMaker anchor_body tag, and 
then opens the image in the Snagit Editor for further modification.

 Quick Styles are image editing presets in the Snagit Editor that make common image editing 
tasks easier and more consistent. For example, there is a palette of Quick Styles for tear-off 
effects. With a single click, you can apply a consistent combination of torn-edge pattern, drop 
shadow, outlining, and affected edges.

Ab Initio custom Profiles summary
The following tables lists the custom Ab Initio Snagit Profile sets.

Ab Initio - General Profile Set

AB_Window Capture entire window

AB_Object Capture single object

AB_Multiple Objects Capture multiple objects

AB_Region Capture rectangular region

AB_Region - auto trim Capture rectangular region, automatically trim excess

AB_Menu with delay Capture drop-down menu

AB_Text from window Capture text from a dialog

Ab Initio - Resize Profile Set

AB_Region - anchor_body Capture region, trim excess, resize to max. anchor_body width 5.36" = 514 pixels

AB_Region - anchor_list Capture region, trim excess, resize to max. anchor_list width 5.161" = 495 pixels

AB_Region - anchor_sublist Capture region, trim excess, resize to max. anchor_sublist width 4.962" = 476 pixels

AB_Region - achor_right Capture region, trim excess, resize to max. anchor_right width 6.815" = 654 pixels

AB_Window - anchor_body Capture window, resize to max. anchor_body width 5.36" = 514 pixels

AB_Window - anchor_list Capture window, resize to max. anchor_list width 5.161" = 495 pixels

AB_Window - anchor_sublist Capture window, resize to max. anchor_sublist width 4.962" = 476 pixels

AB_Window - achor_right Capture window, resize to max. anchor_right width 6.815" = 654 pixels
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Ab Initio custom Quick Styles summary
Custom Quick Style palettes are defined for the following graphical elements:

 Shape Quick Styles

 Line Quick Styles

 Arrow Quick Styles

 Text Quick Styles

 Callout Quick Styles

 Tear-off Quick Styles

Shape Quick Styles

The Shape Quick Style palette, shown below, includes rectangles, rounded rectangles, and ellipses, 
each with both solid and transparent fills, and flat and drop-shadow effects.

The numbers shown in the illustration correspond to the shape parameters listed below.

1 Shape: Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px 
Shadow: SE, 7px

2 Shape: Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px 
Shadow: SE, 7px

3 Shape: Rounded Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px 
Shadow: SE, 7px

4 Shape: Rounded Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px 
Shadow: SE, 7px

5 Shape: Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px

6 Shape: Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px
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Line Quick Styles

The Line Quick Styles palette, shown below, includes solid, dashed, and curved lines, all with drop 
shadows.

The numbers shown in the illustration correspond to the line parameters listed below.

7 Shape: Rounded Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px

8 Shape: Rounded Rectangle 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px

9 Shape: Ellipse 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px 
Shadow: SE, 7px

10 Shape: Ellipse 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px 
Shadow: SE, 7px

11 Shape: Ellipse 
Outline Color: R:192 G:0 B:0 
Fill Color: Transparent 
Width: 2px

12 Shape: Ellipse 
Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Width: 2px

1 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Flat

2 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Flat 
Style: Dash

3 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Flat 
Type: Bezier Curve

4 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Flat 
Style: Dash 
Type: Bezier Curve
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Arrow Quick Styles

The Arrow Quick Style palette, shown below, includes solid, dashed, straight, and curved lines 
with arrows and one end and at both ends, all with drop shadows.

The numbers shown in the illustration correspond to the arrow parameters listed below.

1 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Equilateral Arrow

2 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Equilateral Arrow 
Style: Dash

3 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Equilateral Arrow 
Type: Bezier Curve

4 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Flat 
End Cap: Equilateral Arrow 
Style: Dash 
Type: Bezier Curve

5 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Equilateral Arrow 
End Cap: Equilateral Arrow

6 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Equilateral Arrow 
End Cap: Equilateral Arrow 
Style: Dash

7 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Equilateral Arrow 
End Cap: Equilateral Arrow 
Type: Bezier Curve

8 Color: R:192 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Start Cap: Equilateral Arrow 
End Cap: Equilateral Arrow 
Style: Dash 
Type: Bezier Curve
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Text Quick Styles

The Text Quick Style palette, shown below, includes regular, bold, italic, and bold italic variants of 
10 point NewsGoth Cn BT.

The numbers shown in the illustration correspond to the text parameters listed below.

Callout Quick Styles

The Callout Quick Style palette, shown below, includes regular and bold variants of 10 point 
NewsGoth Cn BT, each in a rectangle and rounded rectangle, with both white and light gray 
backgrounds, and all with drop shadow effects.

The numbers shown in the illustration correspond to the arrow parameters listed below.

1 Color: R:51 G:51 B:51 
Text Font: NewsGoth 
Cn BT, 10pt, not bold, 
not italic, not underline

2 Color: R:51 G:51 B:51 
Text Font: NewsGoth 
Cn BT, 10pt, bold, not 
italic, not underline

3 Color: R:51 G:51 B:51 
Text Font: NewsGoth 
Cn BT, 10pt, not bold, 
italic, not underline

4 Color: R:51 G:51 B:51 
Text Font: NewsGoth 
Cn BT, 10pt, bold, italic, 
not underline

1 Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, not bold, not italic, not 
underline

2 Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, bold, not italic, not 
underline

3 Outline Color: R:192 G:0 B:0 
Fill Color: R:242 G:242 B:242 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, not bold, not italic, not 
underline

4 Outline Color: R:192 G:0 B:0 
Fill Color: R:242 G:242 B:242 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, bold, not italic, not 
underline

5 Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, not bold, not italic, not 
underline

6 Outline Color: R:192 G:0 B:0 
Fill Color: R:255 G:255 B:255 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, bold, not italic, not 
underline
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Tear-off Quick Styles

The Tear-off Quick Styles palette, shown below, use the same style for each combination of 
single edges and corners. That is, the same tear-off style can be applied to any single edge, or to 
the upper left, lower left, upper right, and lower right corners.

All tear-off styles use the following parameters; the only differences are the edges to which the 
tear-offs are applied.

 Edge Effect: Torn (size: 3)

 Borders: Bottom, Right

 Outline: 1px (R:1 G:128 B:128)

 Shadow: SE, 4px

Using Snagit Profiles
You can use a Snagit Profile in any of several ways:

 Click a Profile name in the Snagit OneClick pop-up window to select the profile and initiate 
the screen capture.

 Click a Profile name in the Snagit main application, and then click the large red button in the 
lower right corner of the Snagit application to initiate the screen capture.

 Press the hot key that is assigned to a Profile. By default, the PrtScr hot key initiates a screen 
capture using the Profile that was last selected in the Snagit main window.

7 Outline Color: R:192 G:0 B:0 
Fill Color: R:242 G:242 B:242 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, not bold, not italic, not 
underline

8 Outline Color: R:192 G:0 B:0 
Fill Color: R:242 G:242 B:242 
Text Color: R:204 G:0 B:0 
Width: 2px 
Shadow: SE, 7px 
Style: Plain 
Text Font: NewsGoth Cn BT, 
10pt, bold, not italic, not 
underline
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 Right-click the Snagit icon in the Windows System Tray, and then select the desired Profile 
from the Profiles submenu. Note that you may need to customize the way Windows displays 
the Snagit System Tray icon, as described in Displaying the Snagit icon in the Windows 
System Tray.

 Use the Snait drop-down menu in FrameMaker. The Snagit menu is only available in 
FrameMaker if Snagit was installed after FrameMaker. Note, however, that you may have 
mixed results using the Snagit menu in FrameMaker. Specifically, FrameMaker and/or Snagit 
seem to become unstable when Snagit is run through the FrameMaker menu. Your mileage 
may vary.

Using Snagit Quick Styles
Quick Styles are only available when using the Snagit Editor. To use one of the Quick Styles, 
select the desired tool, and then click the More button on the bottom of the tool palette scroll bar 
to display the full list of available styles for the tool. The Quick Styles are at the bottom of the 
Styles drop-down window. Unfortunatley, there does not appear to be any way to move custom 
Quick Styles to the top of the Styles list. For example, the arrows Quick Styles are shown below.
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Preparing the UI component to be captured
The specific steps for preparing a UI component to be captured vary depending on the type of 
component. Specifically, the preparatory steps differ for graphs, brower-based clients, and dialog 
boxes.

 Image sizing considerations before capture

 Estimating image sizes using an on-screen ruler

 Preparing graphs for capture

 Preparing browser-based clients for capture

 Preparing dialogs for capture

Image sizing considerations before capture
There are several things to remember about image sizing when preparing a UI component for 
screen capture:

 All images, without exception, should be imported into FrameMaker at 96 dpi. This is the 
Snagit default, and it’s all you get when you generate online help from FrameMaker in any 
case, so just stop thinking about it now.

 Never resize, scale, or crop images in FrameMaker. Always do your screen capture resizing in 
Snagit. Similarly, do all callouts, captions, and any other screen capture modifications in 
Snagit. Never use the FrameMaker drawing and captioning tools. Just say no.

 Our primary publication target is online help, so don’t worry too much about print. Because 
we’re less concerned with print publication, forget about print inches; the only thing you need 
to be concerned about is the width, in pixels, of your final image.

 Don’t worry too much about the vertical dimension of your image; it’s not as important as its 
width, as long as the image is no taller than an entire FrameMaker page.

 All images are imported into FrameMaker by reference, and attached to one of our defined 
FrameMaker anchor tags. Unfortunately, due to FrameMaker limitations, our FrameMaker 
anchor tags are defined in terms of inch dimensions rather than pixels. This may lead to some 
confusion regarding how many pixels wide your image can be.

 To sort out inch-to-pixel conversions, refer to the Maximum Pixel Dimensions for Anchored 
Frames table for a list of FrameMaker anchor tags, their maximum dimensions in inches, and 
their corresponding maximum pixel widths.

 To get a sense of the dimensions of the UI component you want to capture, use an on-screen 
ruler, as described in Estimating image sizes using an on-screen ruler.

 If it’s clear that your final image is going to be larger than the maximum width supported by 
any of our FrameMaker anchor tags, use one of the Ab Initio - Resize Profiles, listed in Ab Initio 
custom Profiles summary and described in Choosing a Snagit Profile.
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 Remember that our custom auto-size and auto-trim Snagit Profiles (Ab Initio - Resize), used 
in combinatation with the provided inch-to-pixel conversion table and an on-screen ruler, are 
your friends when it comes to minimizing the dreaded and inefficient trial-and-error sizing 
and refitting of images in FrameMaker.

Estimating image sizes using an on-screen ruler
An on-screen ruler, as the name implies, enables you to measure the dimensions of any item 
displayed on your screen. Such measurements can be helpful when sizing a UI component in 
preparation for screen capture. Depending on the on-screen ruler software you use, measurement 
units can be pixels, inches, millimeters, and suchlike, with pixels being the most useful unit for our 
purposes.

The currently recommended on-screen ruler software for our purposes is the WonderWebWare 
Screen Ruler. Yes, that is indeed one heck of a name... This software is available internally at http:/
/sfordin-7:8080/tools/screenrulersetup.exe.

X To install the WonderWebWare Screen Ruler:

1. Download the installer from http://sfordin-7:8080/tools/screenrulersetup.exe to the directory 
of your choice.

2. Run the installer, and follow the on-screen instructions.

X To use the WonderWebWare Screen Ruler:

1. Select the WonderWebWare Screen Ruler program item from the Wiindows Start > All 
Programs > WonderWebWare Screen Ruler menu.

The Screen Ruler program is displayed with the default settings.

http://sfordin-7:8080/tools/screenrulersetup.exe
http://sfordin-7:8080/tools/screenrulersetup.exe
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2. Right-click on the Screen Ruler window to display a pop-up menu of available commands and 
configuration options.

Of particular interest here are the Stay on TOP option, the Unit submenu, and the 
Transparency submenu.

3. Click Minimize to tray to minimize the Screen Ruler to the Windows System Tray.

4. If the Screen Ruler icon is not visible in the Windows System Tray, refer to the instructions in 
Displaying the Snagit icon in the Windows System Tray.

5. Right-click the Screen Ruler icon in the Windows System Tray, and then choose Show Screen 
Ruler to display the Screen Ruler again.

6. Drag and resize the Screen Ruler as desired over the component you want to measure.

Preparing graphs for capture
Use the following procedure to prepare your GDE-based graphs for capture. If capturing a graph, 
flow, or plan in a browser-based client, refere instead to the instructions in Preparing browser-
based clients for capture.

 NOTE:  These instructions are based on GDE Version 3.1.0.1, Build ID 410997. Instructions for other GDE 

versions and builds may vary.
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X To prepare a GDE-based graph for screen capture:

1. Select View> Zoom > 100% from the GDE main menu to set the graph zoom level to 100%.

Zooming and scaling is done more effectively in Snagit.

2. Select the graph components you want to display. You can do this in either of two ways:

 Select Settings > Preferences from the GDE main menu to display the Preferences dialog, 
and then select items to display from the Details Layer page.
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 Select View > Detail Layers from the GDE main menu, and then select items to display 
from the pop-up menu.

NOTE:  If capturing an entire graph, it is recommended that you show the graph’s Outer Frame.

3. Still in the Preferences dialog, select the Colors page and then choose the Ab Initio theme 
from the Theme drop-down list.
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4. Select Edit > Appearance > Trim Outer Frame (Crop Sides) from the GDE main menu to trim 
the graph to the smallest possible size.

5. If necessary, click on the canvas outside the graph in the GDE to ensure that no component or 
text is inadvertently highlighted.

Preparing browser-based clients for capture
Specific instructions for preparing browser-based clients vary depending on the Web browser you 
are using. In general though, keep the following guidelines in mind:

 Make the browser window as small as possible.

 Use Firefox or Chrome when possible because they provide better CSS support than Internet 
Explorer.

 Set font and image sizes to the default settings, typically 100%.

 Close any irrelevant browser tabs.

 Use a consistent and simple browser theme.
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Preparing dialogs for capture
Specific instructions for preparing dialog boxes will vary depending on the dialog box being 
captured. In general though, keep the following guidelines in mind:

 Make resizable dialogs as small as possible.

 Use a screen ruler if you have doubts about dialog size.

 Use one of the Ab Initio - Resize Profiles if it is clear that a dialog is too large to fit in the 
target anchor tag at full size.

 Be careful about sample data, example names, host names, and IP addresses. See *** for a list 
of naming guidelines.
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Taking a screenshot
After preparing a UI component for capture, there are two primary considerations with regard to 
how you actually perform the capture:

 Choosing a Snagit Profile

 Accessing Snagit

Choosing a Snagit Profile
The best Snagit Profile to use depends on what you want to capture. Briefly, the main features of 
the various types of Profiles are as follows:

 Window — Capture an entire window.

 Region — Drag a rectangle around a region you want to capture.

 Object — Capture an individual object, such as a tool icon or edit box.

 Multiple Objects — Capture multiple objects.

 Menu — Capture a drop-down menu.

 Auto trim — Automatically trim excess from around edges of image.

 Auto size — Automatically resize image to the size defined for the Profile.

See Ab Initio custom Profiles summary for detailed listings of the Ab Initio custom Profiles.

With these general features in mind, some recommendations for which Profile to use include:

 Graph — Use Region with auto trim.

 Browser-based client — Use Object, if possible, otherwise use Region or Window.

 Dialog — Use Window or Object.

 Drop-down list in dialog — Use Region with time delay.

 Button, toolbar, isolated component — Use Object or Multiple Objects.

 Menu — Use Menu with time delay.
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Accessing Snagit
As described in Using Snagit Profiles, there are several ways to take a screenshot using one of the 
Snagit Profiles.

 Using OneClick — Arguably the easiest method, espeically if you need to quickly switch 
among Profiles. See Enabling the Snagit OneClick feature for instructions on enabling this 
feature.

 Using the Snagit main application — Enables you to set the default Profile to use with a 
keyboard shortcut. Also enables you to temporarily customize existing Profiles and create new 
Profiles. For example, you may want to temporarily add a time delay to the Region Profile so 
you can capture a drop-down list in a dialog box. Finally, you can also use the Snagit main 
application to define custom key bindings for any Profile.

 Using the keyboard — By default, the Profile that is currently selected in the Snagit main 
application is bound to the PrtScr key. This makes it possible, for example, to use OneClick to 
switch among Profiles while continuing to have one particular Profile bound to the PrtScr key. 
As mentioned above, you can also define custom key bindings for any Profile in the Snagit 
main application.

 Using the System Tray — You can choose a Profile by right-clicking the Snagit icon in the 
Windows System Tray. See Displaying the Snagit icon in the Windows System Tray for 
instructions on enabling this access method.

 Using FrameMaker — As mentioned in Using Snagit Profiles, if Snagit was installed on your 
system after FrameMaker, there will be a Snagit menu in FrameMaker. Note, however, that 
usng this FrameMaker menu is not recommended because it can sometimes cause Windows 
system stability issues. Morever, this FrameMaker menu does not provide as much flexibility 
as other Snagit access methods.
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Editing a screenshot
The topics in this section explain how — and in what order — you should edit screenshots using 
the Snagit Editor.

The following topics are covered here:

 Image editing overview

 Image editing order of events

 Trimming, cropping, and sizing images after capture

 Using the Quick Style palettes to add drawing elements

 Saving an image

 NOTE:  For additional information about saving images, see “Saving images in P4”.

Image editing overview
Most screenshot modification tasks can be performed within the Snagit Editor. These include:

 Image resizing, scaling, trimming, and cropping

 Creating basic shapes, like rectangles, rounded rectangles, circles, and ellipses

 Creating image captions and callouts

 Creating lines and arrows

 Applying tear-off effects on trimmed edges and spliced images

 Exporting images to PNG format

If your image requires significantly more complex work or creating many elements from scratch 
— launching the image well and truly into the “conceptual illustration” category — you may be 
better served using a true illustration program, like Adobe Illustrator. Similarly, some conceptual 
illustrations that do not contain much or any screenshot content may be better created using 
Adobe Illustrator or Microsoft Visio. This said, the Snagit Editor should suffice for most image 
editing purposes, particularly when the image comprises elements that are mostly derived from 
screenshots.

NOTE:  It cannot be stated enough that you should not under any circumstances use the FrameMaker 

drawing tools for image editing or creation. Instead, use a proper graphics program, like Snagit Editor, 

Adobe Illustrator, or Microsoft Visio.
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Image editing order of events
The order in which you perform your image editing tasks is important because some kinds of edits 
are difficult to reverse, while others produce better or worse results at different points in the 
editing workflow.

In general, you should perform your Snagit Editor image editing tasks in the following order:

1. Trim and crop

2. Resize

3. Apply a tear-off style

4. Expand the canvas, if necessary

5. Create shapes and stamps

6. Create text, lines, and callouts

7. Save the image in SNAG format

8. Export the image to PNG format

Trimming, cropping, and sizing images after capture
Before proceeding with these instructions, it is useful to review some terms:

 Trimming means to remove excess pixels around the edges of an image. These excess pixels 
are defined in terms of some repetetive pixel pattern. For example, the Snagit Editor’s Trim 
function might remove the contiguous white space outside the frame surrounding a graph. 
The AB_Region - auto trim Profile and all of the AB_Region Profiles in the Ab Initio - Resize 
set automatically trim images as soon as use perform the capture.

 Cropping is similar to trimming, except that it is not an automatic process and it does not 
depend on any repetitive pixel pattern. That is, you simply decide what bits of an image you 
want to cut off one or more edges of an image.

 Resizing an image, in the context of Snagit, means changing the number of pixels in an image 
while retaining all content in the image. That is, you are fitting the same image in greater or 
fewer numbers of pixels. The implication is that physical size of the image is altered, and 
image clarity will be affected more or less depending on how much the image is resized. 
Snagit’s sizing algorithms are not particularly sophisticated, so in general, you do not want to 
make images larger; image reduction tends to work much better. Ideally, when resizing an 
image, you should specify new pixel dimensions that are some even multiple of the original 
pixel dimensions. This can help reduce antialiasing and other pixel-roundingt artifacts.

 Scaling, in the context of Snagit, is similar to resizing, except that instead of specifying 
discrete pixel dimensions, you specify some percentage by which an image should be resized, 
leaving the pixel calculations to Snagit. This method can be convenient, but you may need to 
play with the percentage amounts, depending on the original image dimensions, to produce 
the highest quality results. As with image resizing, by pixel counts, Snagit does much better 
when reducing images rather than enlarging them.
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Trimming an image

You should use one of the auto trim Profiles when you know beforehand that you’ll want to trim 
the edges of your screen capture. For example, when capturing a graph, it is recommended in 
many cases that you use the AB_Region - auto trim Profile or one of the AB_Region Profiles in the 
Ab Initio - Resize set to automatically trim your image as soon as use perform the capture.

X To trim an image in Snagit Editor after capture:

1. Click the Trim button on the Image tab in Snagit Editor.

Alternatively, drag any of the sizing handles on the edges and corners of the Snagit Editor 
canvas to trim the parts of the image you don’t want. The image below shows the sizing 
handles on the right, lower-right corner, and bottom of the SnagIt editor canvas.
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Cropping an image

X To crop an image in Snagit Editor after capture:

1. Click the Draw tab in Snagit Editor, and choose the Selection tool

2. Drag a selection box around the area you want to keep in the image.

3. Click the Image tab, and then click the Crop button.

TIP:  As with the Trim tool, you can also drag any of the sizing handles on the edges and 
corners of the Snagit Editor canvas to crop the parts of the image you don’t want. This is 
generally much easier than using the Crop tool.
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Resizing an image

X To resize an image in Snagit Editor after capture:

1. Click the Resize button on the Image tab in Snagit Editor, and then choose Resize Image from 
the pop-up menu.

2. Ensure that the Use smooth scaling and Keep aspect ratio options are selected.

3. Choose the sizing method you want to use:

 Scale by percentage is more convenient, but less accurate.

 Scale to specific size is more accurate, and enables you to specifically set your image to 
one of the FrameMaker anchor tag widths.

Refer to the Maximum Pixel Dimensions for Anchored Frames table for information about 
mapping FrameMaker anchor tags to pixel widths.
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Using the Quick Style palettes to add drawing elements
This section provides instructions for performing the following tasks:

 Using tear-off styles

 Using line styles

 Using arrow styles

 Using shape styles

 Resizing the canvas

 Using text styles

 Using callout boxes

For complete descriptions of the custom Ab Initio Quick Styles, refer to the Ab Initio custom 
Quick Styles summary. For instructions on using the custom Quick Styles in general, see Using 
Snagit Quick Styles.

In most cases, to use a Quick Style, select the item you want to modify, click the desired tool, and 
then click the style you want to apply.

Using tear-off styles

X To apply a tear-off (torn edge) style in Snagit Editor:

1. Click the Image tab in Snagit Editor.

2. Drag a selection around the area to which you want to apply the tear-off style.

TIP:  If you are applying the tear-off style to the entire image, you can skip this step.

3. Click the tear-off style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

Scott Fordin

Scott Fordin



AB INITIO CONFIDENTIAL AND PROPRIETARY — DO NOT COPY 47
DRAFT  INTERNAL USE ONLY

Using line styles

X To apply a line style in Snagit Editor:

1. Click the Line tool on the Draw tab in Snagit Editor.

2. Click the line style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

3. Draw the line, as desired.

Using arrow styles

X To apply a arrow style in Snagit Editor:

1. Click the Arrow tool on the Draw tab in Snagit Editor.

2. Click the arrow style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

3. Draw the arrowed line, as desired.
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Using shape styles

X To apply a shape style in Snagit Editor:

1. Click the Line tool on the Draw tab in Snagit Editor.

2. Click the shape style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

3. Draw the shape, as desired.

TIP:  Hold down the Shift key when drawing to make a square or circle with the Rectangle or Ellipse 

tools, respectively.

Resizing the canvas

Most callout text should be added outside the main image. Because of this, it is often necessary 
to create some white space around your image before creating your callout text.

TIP:  Remember to account for this extra white space when planning your final image size.

NOTE:  Callout text should generally be added above or below the main image, if possible. Try to avoid 

adding callouts on the sides of an image.

X To resize the canvas in Snagit Editor:

1. Click the Resize button on the Image tab in Snagit Editor, and then choose Resize Canvas from 
the pop-up menu.

TIP:  Similar to image trimming and cropping,, you can also expand the canvas size by simply 

dragging the canvas sizing handles. Using the Resize Canvas dialog box, as described in this 

procedure, is useful when you need to restrict the canvas to a specific size.
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2. Specify the new canvas dimensions.

3. Choose origin point for where you want the canvas to be added.

For example, to add canvas space above the main image, click the center up arrow in the 
Image placement matrix.

4. Ensure that the Canvas color is set to white.

Using text styles

X To apply a text style in Snagit Editor:

1. Click the Text tool on the Draw tab in Snagit Editor.
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2. Click the text style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

3. Drag a selection rectangle to define the area where you want to create the text.

4. Type the desired text.

5. Click the frame of the selection rectangle around the text to display a pop-up menu of 
formatting options.

6. Click the paragraph alignment drop-down menu.

7. Apply the following paragraph formatting, depending on where your callout line, if any, will be 
attached:

 If attached on the left, use Left paragraph alignment.

 If attached on the right, use Right paragraph alignment.

 If attached in the center, use Center paragraph alignment.

8. If using callout lines, be sure to use the straight solid line Quick Style, as described in Line 
Quick Styles.
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Using callout boxes

X To apply a Callout box Quick Style in Snagit Editor:

1. To click the Callout tool on the Draw tab in Snagit Editor.

2. Click the callout style you want to apply.

Remember that the custom Ab Initio styles will be at the bottom of the list.

3. Drag a selection rectangle to define the area where you want to create the callout box.

4. Type the desired text.

Saving an image
All images should be imported into FrameMaker in PNG format. However, your orginal image 
should be saved in native Snagit (SNAG) format first, and then exported to PNG format. SNAG 
format maintains the editability of text, callouts, shapes, lines, and arrows, which is important for 
localization, reusability, and general image maintenance.

Saving an image in SNAG format

X To save an image in SNAG format:

1. Click the circle in the upper-left corner of the Snagit Editor to display the main menu.
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2. Click Save As, and then select Snagit Capture File for the format.

3. Name the file as desired.

NOTE:  Image files should be saved in a figures subdirectory of the directory in which the Frame 

(.fm) document containing the images is located. See “Saving images in P4” for more information.

Saving an image in PNG format

X To export a SNAG image in PNG format:

1. Click the circle in the upper-left corner of the Snagit Editor to display the main menu.
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2. Click Convert Images to start the conversion wizard.

TIP:  Snagit supports batch image conversion, which means you can convert multiple files in a single 

pass. Click the Add Files button to add files to the conversion queue.

3. Click Next to progress to the Conversion Filters page.
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4. Ensure that no Conversion filters are active, and then click Next to progress to the 
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5. Ensure that PNG format is selected, and then click the Options button.

6. Ensure that the True color (24-Bit) Colors option is selected, and then click OK.

7. Click Next in the Output Options dialog to progress to the final step in the wizard.

8. Click Finish to the convert the file or files (if performing a batch conversion).
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Saving images in P4
There are several scenarios you may encounter when deciding where to save your image files.

 Common scenario

 Scenario in which the document file is not located in the book directory

 Scenario in which the image file is used in more than one document

 Scenario in which the image is of general interest

Common scenario
Typically, a Frame book comprises a .book file and one or more component .fm document 
files.The directory in which these Frame .book and .fm files are located should also contain a 
subdirectory, named figures (all lowercase). Any image file that is referenced in any of the .fm 
document files for the book should be located in this figures subdirectory.

For example, say you have a Frame book named foobar.book, and this book contains one 
document file named chapter_foo.fm, in which an image file named image_bar.png is referenced. 
Your directory structure should be as follows:

.\some-P4-directory
   foobar.book
   chapter_foo.fm
      \figures
      image_bar.png

Scenario in which the document file is not located in the book directory
In some cases, an .fm document file that is associated with a particular book may be located in a 
directory other than the one in which the .book file is located. In such cases, the image file should 
be located in a figures subdirectory of the directory that contains the .fm document file, rather 
than a figures subdirectory of the directory that contains the .book file.

For example, say your book file is still named foobar. book, but the document file, 
chapter_foo.fm, is now located in a different directory. To reference the image_bar.png image file 
in chapter_foo.fm, your directory structure should look something like the following:

.\some-P4-directory
   foobar.book
.\some-other-P4-directory
   chapter_foo.fm
      \figures
      image_bar.png

The important thing here is that the image file must be physically located in a figures 
subdirectory of the directory containing the document in which the image is referenced.
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Scenario in which the image file is used in more than one document
If an image will be used in more than one .fm document file, and the other document file or files 
are located in different directories, do not simply reference the image file in FrameMaker such 
that the path to the image file spans directory trees. Instead, copy the image file to a figures 
subdirectory of the directory that contains the .fm document file.

 TIP:  Again, the important thing here is that the image file must be physically located in a figures 

subdirectory of the directory containing the document in which the image is referenced.

To put this another way, do not reference files across book directories or in any way that requires 
walking up directory trees. This is really important for both production and localization purposes.

For example, say you have a Frame document named .\appetizers\chapter_salad.fm, which 
references an image file named .\appetizers\figures\small_fork.png, You now want to use that 
same image file in another Frame document, named .\desserts\chapter_truffle.fm., located in a 
different directory. In this case, you should not directly reference the image file from the 
.\appetizers\figures directory. Instead, copy the image file to a figures subdirectory in .\deserts 
and then reference the image file from there.

To put this yet another way:

Scenario in which the image is of general interest
If the image is of general interest to authors other than yourself, and is likely to be used in some 
arbitrary number of other books, the image should be saved in the P4 
.\main\doc_central\eng\Figures-Common directory.

 NOTE:  The Figures-Common directory is the sole exception to the “don’t walk directory trees” rule, 

explained in “Scenario in which the image file is used in more than one document”.

This...

.\appetizers
   chapter_salad.fm
   \figures
   small_fork.png

.\desserts
   chapter_truffle.fm
   \figures
   small_fork.png

Not this...

.\appetizers
   chapter_salad.fm
   \figures
   small_fork.png

.\desserts
   chapter_truffle.fm
..\appetizers\figures\small_fork.png
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Resizing Visio drawings
 NOTE:  While not technically a screen capture issue, instructions for resizing Visio drawings are provided 

here until there is time to incorporate this content elsewhere in an omnibus graphics chapter in the 

Writer’s Guide.

Resizing an entire Visio drawing in preparation for incorporating the drawing in a FrameMaker 
document is surprisingly difficult. There is simply no direct, user-friendly method for resizing an 
entire image during the drawing phase. The problem is that shapes and text in Visio are handled 
with entirely different tools and resized based on different algorithms, which means that they 
change sizes in different ways, even when done in a single resizing step. For example, you can 
select everything in a Visio drawing, group it, and then resize it, but the shapes and the text don't 
resize together, and the text ends up repositioned and wrapped in all sorts of undesirable ways.

 NOTE:  As mentioned elsewhere, you may be tempted, but do not resize your Visio drawings in 

FrameMaker using the FrameMaker drawing tools! Instead, use the procedure described in these 

instructions.

Getting shapes and text to all resize nicely together can be done to a certain extent 
programmatically by defining equations on the ResizeMode element in the shape's or text's 
Shapesheet (Developer toolbar). However, this a VisualBasic thing that is not for the faint of 
heart, and equations must be created for each shape, text block, or stencil. It doesn't work in any 
case for grouped elements, and it really isn't practical when trying to resize an entire image after 
the fact while drawing.

There are at least two solutions to this Visio resizing problem, each one applied after the drawing 
phase:

 Solution #1 — Save the Visio drawing as a PNG image, and then resize the PNG in Snagit 
Editor. This works reasonably well, but is not the preferred solution. The problem with this 
solution is that the text in the image is resized after it has already been rasterized, which can 
introduce antialiasing issues depending on the scaling factor. Again, this solution works, but 
the results are generally not as good as Solution #2.

 Solution #2 — Use the Visio PNG Output Options dialog to specify the image output size 
when saving the drawing in PNG format. This is the preferred solution because it leverages the 
same "it's really text" characteristics of text in Visio drawings that makes resizing during the 
drawing phase such a pain. There are two nice things about this solution:

 Text resizing is based on real text metrics rather than rasters, which minimizes antialiasing 
issues.

 You can do everything within Visio, so you don't have to open a second editing tool.

Instructions for Solution #2 are provided below.
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X To resize a Visio drawing when exporting it to PNG format:

1. Edit your image normally in Visio, and save it in native Visio VSD format.

2. Select File > Save As from the Visio main menu to open the Save As dialog.

3. Select PNG format for the Save as type, and then click Save to open the PNG Output Options 
dialog.

4. Select the following PNG output options.
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a. Color format: 24-bit color

b. Background color: white, Transparency color not selected

c. Resolution: Custom, 96x96 pixels/inch

d. Size: Custom; specify desired output size; this is where the actual image scaling happens 
(see Tips, below)

e. Size: Use pixels

5. Click OK to export the image in PNG format using at the specified size.

 TIP:  Some tips and notes for specifying image size in the Visio PNG Output Options dialog:

 Be aware that the Custom width and height Size fields (label D in the illustration above) 
are not linked or constrained by aspect ratio. What this means is that it is possible to enter 
values that make your image all squished or flattened (technical terms). It is up to you to 
figure out the best values to use to maintain the aspect ratio of your resized image.

 Following on the first tip, you may want to use a calculator to figure out the new height 
and width values. Refer to “Maximum Pixel Dimensions for Anchored Frames” and 
“Common Aspect Ratios” for useful tables of values.

 When calculating image sizes, try as much as possible to use divisors that result in whole 
numbers to avoid pixel rounding errors. For example, scaling 250 pixels by 75% produces a 
value of 187.5 pixels, whereas scaling it by 74% produces a value of 185 pixels.

 Note that Visio wants to remember the last values you entered for pixel height and width. 
To quickly restore these values to the actual image size, click the one of the radio buttons 
above the Custom button in the Size area of the dialog to reset the values, and then click 
Custom again. You'll have to select pixels as the unit again, but it's much easier than 
trying to remember what the original image size values were.

Scott Fordin

Scott Fordin



AB INITIO CONFIDENTIAL AND PROPRIETARY — DO NOT COPY 61
DRAFT  INTERNAL USE ONLY

Importing an image into FrameMaker
(Explained in main Writer’s Guide.)

Creating an anchored frame

Creating ImgAltText tags
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Review: Screenshot order of events
It may be useful at this point to review the overall sequence of procedures for creating, 
modifying, saving, and importing screenshots into FrameMaker.

1. Configuring your Windows 7 desktop envrionment

2. Preparing the UI component to be captured

3. Choosing a Snagit Profile

4. Taking a screenshot

5. Editing a screenshot

6. Saving an image in SNAG format

7. Saving an image in PNG format

8. Saving images in P4

9. Importing an image into FrameMaker
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Useful screenshot-related numbers

Maximum Pixel Dimensions for Anchored Frames
The following table maps our FrameMaker anchor tags to their print dimensions in inches and the 
corresponding maximum pixel width for a graphics frame attached the anchor tag. These 
maximum anchor tag-oriented pixel widths are useful when calculating target image sizes.

Common Aspect Ratios
The following table maps common computer screen resolutions to their corresponding aspect 
ratios. These ratios are useful when selecting graphical elements and cropping and resizing 
images.

FrameMaker Tag Max Width (inches) Max Width (pixels)

anchor_body 5.36 514

anchor_list 5.161 495

anchor_sublist 4.962 476

anchor_right 6.815 654

no tag; print 2.5" 2.5 240

Screen Resolution Aspect Ratio

1920 x 1200 0.625

1280 x 800 0.625

1024 x 768 0.75

800 x 600 0.75

640 x 480 0.75
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